The service is restored and we are monitoring email reprocessing
Posted Sep 18, 2025 - 07:32 EDT
Update
The service is now partially recovered and we are reprocessing emails from this morning
Posted Sep 18, 2025 - 07:15 EDT
Update
The restoration of our services is still in progress, it should be completed shortly. We will provide another update in the next 30 minutes.
Posted Sep 18, 2025 - 06:50 EDT
Update
The restoration of our services is in progress, it should be completed shortly. We will provide another update in the next 30 minutes.
Posted Sep 18, 2025 - 06:12 EDT
Update
The root cause has been identified and our team is working on restoring our services as quickly as possible. We are very sorry about this incident and will provide next update in 30 minutes
Posted Sep 18, 2025 - 05:19 EDT
Update
The fix is still in progress. Our team is dedicated on fixing the issue. Next update in 30 minutes
Posted Sep 18, 2025 - 04:00 EDT
Update
The fix is still in progress. Our team is dedicated on fixing the issue. Next update in 30 minutes
Posted Sep 18, 2025 - 03:10 EDT
Update
We have identified the issue. The fix is in progress
Posted Sep 18, 2025 - 02:46 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2025 - 02:23 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 18, 2025 - 02:07 EDT
This incident affected: Shipfix (Email API, Email Inbound, Email Outbound, Email Processing, Market Monitor, Maps, Data Insights, Vessel & Port Directory).